Maximum sum
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 32007 | Accepted: 9855 |
Description
Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).![]()
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1 10 1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
Huge input,scanf is recommended.
题解:第一次做动态规划题,参照博客的。
1.明白最大连续子段。
2.我感觉做法是的暴力,(1)求1->i所有的最大和,(2)求n->i的最大和,(3)分别优化2个最大和.(4)求2个最大和的最大值即为所求。
AC code:
#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
#define max(a,b) a>b?a:b
int main(){
int dplift[50001],dpright[50001],i,n,t,sum,a[50001];
scanf("%d",&t);
while(t--){
//cin>>n; 注意用c语言输入,否则超时
scanf("%d",&n);
for(i=1;i<=n;i++)
// cin>>a[i];
scanf("%d",&a[i]);
dplift[1]=a[1];
for(i=2;i<=n;i++)
{
if(dplift[i-1]>0)
dplift[i]=dplift[i-1]+a[i];
else
dplift[i]=a[i];
}
for(i=2; i<=n; i++)
dplift[i]=max(dplift[i],dplift[i-1]);
dpright[n]=a[n];
for(i=n-1;i>0;i--)
if(dpright[i+1]>0)
dpright[i]=dpright[i+1]+a[i];
else
dpright[i]=a[i];
for(i = n-1;i>0;i--)
dpright[i]=max(dpright[i+1],dpright[i]);
sum=dplift[1]+dpright[2];
for(i=2; i<n;i++)
if(dplift[i]+dpright[i+1]>sum)
sum=dplift[i]+dpright[i+1];
// cout<<sum<<endl;
printf("%d\n",sum);
}
return 0;
}
还有一道类似的注意范围,v_v,被坑了。