POJ 2479 Maximum sum


Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32007 Accepted: 9855

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.
题解:第一次做动态规划题,参照博客的。
1.明白最大连续子段
2.我感觉做法是的暴力,(1)求1->i所有的最大和,(2)求n->i的最大和,(3)分别优化2个最大和.(4)求2个最大和的最大值即为所求。
AC code:
#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
#define max(a,b)  a>b?a:b
int main(){

	int dplift[50001],dpright[50001],i,n,t,sum,a[50001];
       scanf("%d",&t);
		while(t--){
			//cin>>n;  注意用c语言输入,否则超时
			scanf("%d",&n);
			for(i=1;i<=n;i++)
			//	cin>>a[i];
			scanf("%d",&a[i]);
			dplift[1]=a[1];
			for(i=2;i<=n;i++)
			{
				if(dplift[i-1]>0)
					dplift[i]=dplift[i-1]+a[i];
				else
					dplift[i]=a[i];
			}
			for(i=2; i<=n; i++)
			dplift[i]=max(dplift[i],dplift[i-1]);
			dpright[n]=a[n];
			for(i=n-1;i>0;i--)
				if(dpright[i+1]>0)
					dpright[i]=dpright[i+1]+a[i];
				else
					dpright[i]=a[i];
			for(i = n-1;i>0;i--)
				dpright[i]=max(dpright[i+1],dpright[i]);
			sum=dplift[1]+dpright[2];
			for(i=2; i<n;i++)
				if(dplift[i]+dpright[i+1]>sum)
					sum=dplift[i]+dpright[i+1];
			//	cout<<sum<<endl;
				printf("%d\n",sum);

		}

	return 0;
}

还有一道类似的注意范围,v_v,被坑了。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值