poj3624Charm Bracelet

本文介绍了一道关于选择最佳组合的魅力手链问题。在给定重量限制和一系列魅力物件的重量与吸引力评分的情况下,需要找到最大总吸引力评分的组合。通过使用类似于01背包问题的动态规划方法解决此问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27837 Accepted: 12534

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver



其实题  不是看的懂,看输出有点像01背包,然后就a了。

附代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long ans[1100000],weight[1100000],weath[1100000],i,j,k,l,m,n;//数组要开的大 
int main()
{
	
	while(scanf("%ld%ld",&m,&n)!=EOF)
	{
		
	memset(ans,0,sizeof(ans));
	for(i=1;i<=m;i++)
	scanf("%ld%ld",&weight[i],&weath[i]);
	
	
	for(i=1;i<=m;i++)
	for(j=n;j>=weight[i];j--)
	ans[j]=max(ans[j],ans[j-weight[i]]+weath[i]);
	printf("%ld\n",ans[n]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值