Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 27837 | Accepted: 12534 |
Description
Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6 1 4 2 6 3 12 2 7
Sample Output
23
Source
其实题 不是看的懂,看输出有点像01背包,然后就a了。
附代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long ans[1100000],weight[1100000],weath[1100000],i,j,k,l,m,n;//数组要开的大
int main()
{
while(scanf("%ld%ld",&m,&n)!=EOF)
{
memset(ans,0,sizeof(ans));
for(i=1;i<=m;i++)
scanf("%ld%ld",&weight[i],&weath[i]);
for(i=1;i<=m;i++)
for(j=n;j>=weight[i];j--)
ans[j]=max(ans[j],ans[j-weight[i]]+weath[i]);
printf("%ld\n",ans[n]);
}
}