L2-005. 集合相似度
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
给定两个整数集合,它们的相似度定义为:Nc/Nt*100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。
输入格式:
输入第一行给出一个正整数N(<=50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(<=104),是集合中元素的个数;然后跟M个[0, 109]区间内的整数。
之后一行给出一个正整数K(<=2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。
输出格式:
对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。
输入样例:3 3 99 87 101 4 87 101 5 87 7 99 101 18 5 135 18 99 2 1 2 1 3输出样例:
50.00% 33.33%
首先把每一个集合 用stl的set(集合)存下来。
对于给出的一组查询,b = 两集合的元素个数之和。 然后遍历一个集合, 检查其中的元素是否在另一个集合里, 由此得出 a , 然后代入公式计算就可以了。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<set>
#include<algorithm>
#define fin freopen("in.txt", "r", stdin)
#define mem(a,b) memset(a, b, sizeof(a) )
#define f(x) p[x].first
#define s(x) p[x].second
#define sf(x) p[x].second.first
#define ss(x) p[x].second.second
using namespace std;
typedef pair<int, int> P;
set<int> s [55];
set<int>::iterator it;
int n, k;
int main ()
{
scanf("%d", &n);
for(int i= 1; i<= n; i++){
int t, m;
scanf("%d", &m);
for(int j= 0; j< m; j++){
scanf("%d", &t);
s[i].insert(t);
}
}
scanf("%d", &k);
while( k-- ){
int x, y;
scanf("%d %d", &x, &y);
int a = s[x].size() + s[y].size(), b = 0;
/*******敲黑板,划重点*******/
for(it= s[x].begin(); it!= s[x].end(); it++){
if(s[y].count(*it) ) b++;
}
double ans = 100 * ( 1.0 * b / (a-b) );
printf("%.2f%c\n",ans , '%');
}
return 0;
}