Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 19452 Accepted Submission(s): 11701
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10 1 3 6 9 0 8 5 7 4 2
Sample Output
16
大致题意:
对于给出的数组,每次把第一个元素挪到最后,求此过程中最小的逆序数。
大体思路:
可以用归并排序求。这里说用线段树的解法。
处理初始数组:对于每一个数,查找线段树中已有的比他大的数的数量。之后把这个数加入线段树。
每一次移动:假设这次移动的是m,则他后面比m小的有 m-1 个,比m大的有 n-m个,所以新的逆序数等于 原来的逆序数 - (m-1) + n - m.
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define _max 5010
int Seg [_max<<2];
int A [_max] ;
int n ;
int Query (int p, int l, int r, int x, int y)
{
if(x<=l && y>=r) return Seg[p];
int mid = (l+r)>>1,ans = 0;
if(x<=mid) ans += Query(2*p, l, mid, x, y);
if(y> mid) ans += Query(2*p+1, mid+1, r, x, y);
return ans;
}
void Update (int p, int l, int r, int x)
{
if(l==r){
Seg[p]++;
return;
}
int mid = (l+r)>>1;
if(x<=mid) Update(2*p, l, mid, x);
else Update(2*p+1, mid+1, r, x);
Seg[p] = Seg[2*p] + Seg[2*p+1];
}
int main ()
{
//freopen("in.txt","r",stdin);
while(scanf("%d",&n) != EOF){
memset(Seg,0,sizeof(Seg));
for( int i=1; i<=n; i++){
scanf("%d",A+i);
A[i]++;
}
int ans = 0 ;
for(int i=1; i<=n; i++){
ans += Query(1, 1, n, A[i], n);
Update(1, 1, n, A[i]);
}
int Min = ans;
for(int i=1; i<=n; i++){
ans = ans - A[i] + 1 + n - A[i] ;
if(ans<Min) Min = ans ;
}
printf("%d\n",Min);
}
return 0 ;
}