HDU1394_Minimum Inversion Number_线段树求逆序数

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19452    Accepted Submission(s): 11701


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16

大致题意:

对于给出的数组,每次把第一个元素挪到最后,求此过程中最小的逆序数。

大体思路:

可以用归并排序求。这里说用线段树的解法。

处理初始数组:对于每一个数,查找线段树中已有的比他大的数的数量。之后把这个数加入线段树。

每一次移动:假设这次移动的是m,则他后面比m小的有 m-1 个,比m大的有 n-m个,所以新的逆序数等于 原来的逆序数 - (m-1) + n - m.


#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;

#define _max 5010

int Seg [_max<<2];
int A [_max] ;
int n ;

int Query (int p, int l, int r, int x, int y)
{
	if(x<=l && y>=r) return Seg[p];
	int mid = (l+r)>>1,ans = 0;
	if(x<=mid) ans += Query(2*p, l, mid, x, y);
	if(y> mid) ans += Query(2*p+1, mid+1, r, x, y);
	return ans;
}

void Update (int p, int l, int r, int x)
{
	if(l==r){
		Seg[p]++;
		return;
	}
	int mid = (l+r)>>1;
	if(x<=mid) Update(2*p, l, mid, x);
	else Update(2*p+1, mid+1, r, x);
	Seg[p] = Seg[2*p] + Seg[2*p+1];
}

int main ()
{
	//freopen("in.txt","r",stdin);

	while(scanf("%d",&n) != EOF){

		memset(Seg,0,sizeof(Seg));

		for( int i=1; i<=n; i++){
			scanf("%d",A+i);
			A[i]++;
		}

		int ans = 0 ;
		for(int i=1; i<=n; i++){
			ans += Query(1, 1, n, A[i], n);
			Update(1, 1, n, A[i]);
		}

		int Min = ans;
		for(int i=1; i<=n; i++){
			ans = ans - A[i] + 1 + n - A[i] ;
			if(ans<Min) Min = ans ;
		}

		printf("%d\n",Min);

	}

	return 0 ;

}



内容概要:本文详细探讨了双馈风力发电机(DFIG)在Simulink环境下的建模方法及其在不同风速条件下的电流与电压波形特征。首先介绍了DFIG的基本原理,即定子直接接入电网,转子通过双向变流器连接电网的特点。接着阐述了Simulink模型的具体搭建步骤,包括风力机模型、传动系统模型、DFIG本体模型和变流器模型的建立。文中强调了变流器控制算法的重要性,特别是在应对风速变化时,通过实时调整转子侧的电压和电流,确保电流和电压波形的良好特性。此外,文章还讨论了模型中的关键技术和挑战,如转子电流环控制策略、低电压穿越性能、直流母线电压脉动等问题,并提供了具体的解决方案和技术细节。最终,通过对故障工况的仿真测试,验证了所建模型的有效性和优越性。 适用人群:从事风力发电研究的技术人员、高校相关专业师生、对电力电子控制系统感兴趣的工程技术人员。 使用场景及目标:适用于希望深入了解DFIG工作原理、掌握Simulink建模技能的研究人员;旨在帮助读者理解DFIG在不同风速条件下的动态响应机制,为优化风力发电系统的控制策略提供理论依据和技术支持。 其他说明:文章不仅提供了详细的理论解释,还附有大量Matlab/Simulink代码片段,便于读者进行实践操作。同时,针对一些常见问题给出了实用的调试技巧,有助于提高仿真的准确性和可靠性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值