Factstone Benchmark
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1220 Accepted Submission(s): 706
Problem Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.
Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?
There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.
Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?
There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.
Sample Input
1960 1981 0
Sample Output
3 8
Source
Recommend
Eddy
//求n! < 2^m最大的n,其中m为计算机位数。
//两边对数:log(1) + log(2) +...+ log(n) < m* log(2)。
#include <stdio.h>
#include <math.h>
int main()
{
int t, n, i;
double r;
while (~scanf("%d", &t), t)
{
n = (t - 1960) / 10 + 2;
n = 1 << n;
r = 0;
i = 1;
while (r < n)
{
r += log(i++) / log(2);
}
printf("%d\n", i-2);
}
return 0;
}