Lowest Common Multiple Plus
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21992 Accepted Submission(s): 8921
Problem Description
求n个数的最小公倍数。
Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
Sample Input
2 4 6 3 2 5 7
Sample Output
12 70
Author
lcy
Source
Recommend
lcy
#include <iostream>
using namespace std;
int GCD(int a, int b)
{
if (a < b)
{
int temp = a;
a = b;
b =temp;
}
if(a % b == 0)
return b;
else return GCD(b, a%b);
}
int LCM(int a, int b)
{
return a/GCD(a, b)*b;//the postion of b is important
}
int main()
{
int n,m,i;
while (cin>>n)
{
int s = 1;
for (i = 0; i < n; i++)
{
cin>>m;
s = LCM(s, m);
}
cout<<s<<endl;
}
return 0;
}