Uva10881 Piotr’s Ants

该博客主要介绍了UVA在线判题系统中的一道题目——Piotr's Ants。题目要求编写程序模拟蚂蚁在一根杆子上行走的过程,蚂蚁会根据碰撞改变方向,或者掉下杆子。输入包含蚂蚁的位置和初始朝向,输出在指定时间后的状态。程序使用了排序和搜索算法来解决此问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Uva10881 Piotr’s Ants

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 ≤ n ≤ 10000). The next n lines give the locations of the n ants
(measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output
For each test case, output one line containing ‘Case #x:’ followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print ‘Turning’ instead of ‘L’ or ‘R’ for their direction. If an ant falls off the pole before T seconds, print ‘Fell off’ for that ant. Print an empty line after each test case.

Sample Input
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Sample Output
Case #1:
2 Turning
6 R
2 Turning
Fell off
Case #2:
3 L
6 R
10 R

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e5+10;
struct infor{
	int wei;
	int turn;
	int id; 
}ant[maxn];
bool cmp(infor x,infor y){
	return x.wei < y.wei;
}
int main(){
	int t;
	cin >> t;
	int cnt = 1;
	while(t--){
		int n;
		int L,T;
		cin >> L >> T >> n;
		char fx;
		memset(ant,0,sizeof(ant));
		for(int i=0;i<n;i++){
			cin >> ant[i].wei >> fx;
			if(fx=='R') ant[i].turn = 1;
			else ant[i].turn = -1;
			ant[i].id = i;
		}
		sort(ant,ant+n,cmp);
		int order[maxn];
		for(int i=0;i<n;i++){
			order[ant[i].id] = i;
		}
		for(int i=0;i<n;i++){
			ant[i].wei += ant[i].turn*T;
		}
		sort(ant,ant+n,cmp);
		for(int i=1;i<n;i++){
			if(ant[i].wei==ant[i-1].wei) ant[i].turn = ant[i-1].turn = 0;
		}
		cout<<"Case #"<< cnt <<":"<<endl;
		cnt++;
		for(int i=0;i<n;i++){
			int node = order[i];
			if(ant[node].wei<0||ant[node].wei>L) cout << "Fell off" << endl;
			else{
				if(ant[node].turn==1) cout << ant[node].wei << " " << "R" << endl;
				else if(ant[node].turn == -1) cout << ant[node].wei << " " << "L" << endl;
				else cout << ant[node].wei << " " << "Turning" << endl;
			}
		}
		cout << endl;
	}
	return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值