ACM与蓝桥杯竞赛指南 基本输入输出格式四

 A+B for Input-Output Practice (IV)

题目描述:

Your task is to Calculate the sum of some integers.

输入格式:

 Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

输出格式:

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

样例输入: 

4 1 2 3 4 
5 1 2 3 4 5 
0

 样例输出:

10 
15

想必结合题意和样例,大家已经明白题目考察点了,就是累加求和,只不过个数n需要提前指定,为0表示结束,故而我们可以先接收n并且判断n非0再进入循环,循环n次累加求和

参考C语言代码:

#include<stdio.h>
int main()
{
  int n;
  int sum,temp;
  while(scanf("%d",&n) && n)
  {
      sum=0;
      while(n--)
      {
          scanf("%d",&temp);
              sum+=temp;
      }
      printf("%d\n",sum);
  }
  return 0;
}

注意本题,为双重循环,每次累加求和的sum一定要每次都要归零!这是一个易错点

参考C++写法:

#include<iostream>
using namespace std;
int main()
{
    int n,x;
    while(cin>>n && n)
    {
      int sum=0;
      while(n--)
      {
        cin>>x;
        sum+=x;
      }
      cout<<sum<<endl;
    }
    return  0;
}

参考Java代码:

import java.util.Scanner;
 
public class Main {
    public static void main(String[] args) {
 
        Scanner scanner = new Scanner(System.in);
        while (scanner.hasNext()) {
            int sum=0;
            int n = scanner.nextInt();
            if(n==0) 
                break;
            while (n--!=0){
                 int a=scanner.nextInt();
                 sum=sum+a;
            }
            System.out.println(sum);
             
        }
    }
}

参考Python代码:

while True: 
  sum=0 
  list=input().split()
  if list[0]=='0':
      break 
  for i in range(1,len(list)):
      list[i]=int(list[i])
      sum+=list[i]
  print(sum)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

赔罪

你的鼓励将是我最大的动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值