POJ 2586 How far away ? LCA

http://acm.hdu.edu.cn/showproblem.php?pid=2586

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

思路:LCA模板题。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;

const int maxn=4e4+5;

struct edge
{
    int to,nxt;
    ll dis;
};

edge Edge[maxn<<1];
int head[maxn];
int fa[maxn];//父节点
int deep[maxn];//深度
ll dist[maxn];
int n,m,cnt=0;
int f[maxn][30];

inline void addedge(int u,int v,ll dis)
{
    Edge[++cnt].to=v,Edge[cnt].nxt=head[u],Edge[cnt].dis=dis,head[u]=cnt;
    Edge[++cnt].to=u,Edge[cnt].nxt=head[v],Edge[cnt].dis=dis,head[v]=cnt;
}

void dfs(int u,int father)
{
    deep[u]=deep[father]+1;
    f[u][0]=father;
    for(int i=1;i<=20;i++)
	f[u][i]=f[f[u][i-1]][i-1];
    for(int i=head[u];i;i=Edge[i].nxt)
    {
        if(Edge[i].to!=father)
        {
            dist[Edge[i].to]=dist[u]+Edge[i].dis;
            dfs(Edge[i].to,u);
        }
    }
}

inline int skip(int x,int level)
{
    for(int i=20;i>=0;i--)
        if((1<<i)&level)
            x=f[x][i];
    return x;
}

inline int LCA(int u,int v)
{
    if(deep[u]<deep[v])
        swap(u,v);
    u=skip(u,deep[u]-deep[v]);
    if(u==v)
        return u;
    for(int i=20;i>=0;i--)
        if(f[u][i]!=f[v][i])
            u=f[u][i],v=f[v][i];
    return f[u][0];
}

int main()
{
    int t,u,v,grand;
    ll dis;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        cnt=0;
        memset(head,0,sizeof(head));
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%lld",&u,&v,&dis);
            addedge(u,v,dis);
        }
        dfs(1,0);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            grand=LCA(u,v);
            printf("%lld\n",dist[u]+dist[v]-2*dist[grand]);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值