PAT (Advanced Level) Practice
题目链接.
- 编程题 1001 A+B Format (20 分)
1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
参考代码
#include<iostream>
using namespace std;
int main(){
int a, b;
cin >> a >> b;
string s = to_string(a + b);
int len = s.length();
for (int i = 0; i < len; i++){
cout << s[i];
if (s[i] == '-') continue;
if ((i+1)%3 == len % 3 && i != len -1) cout << ",";
}
return 0;
}
小伙伴们可以去写更棒的方法哦