HDU 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 137183    Accepted Submission(s): 31788


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

跟上一题一样。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int a[100005];
int dp[100005];

int main()
{
    int t,i,j,n;
    scanf("%d",&t);

    for(i=1;i<=t;i++)
    {
        scanf("%d",&n);
        for(j=1;j<=n;j++)
            scanf("%d",&a[j]);

        dp[1]=a[1];
        int r=1,l=1,current=1;
        int ma=-1;

        for(j=2;j<=n;j++)
        {
            if(dp[j-1]>=0)//确定dp[j]的值
                dp[j]=dp[j-1]+a[j];

            else
            {
                dp[j]=a[j];
                current=j;//current是个中间变量,保存起点的值
            }//先求出dp[j]的大小然后跟ma比较,在判断起点终点,否则是没有意义的,所以先用current保存起点的值,而终点的值就是当前值,更新的时候起点不一定换但终点一定换
            if(dp[j]>=ma)//确定起点终点,这个=要有,没有会wa
            {
                ma=dp[j];
                r=j;
                l=current;
            }
        }

        printf("Case %d:\n",i);
        printf("%d %d %d\n",ma,l,r);
        if(i!=t)
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值