Description
A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct.
Being the team's leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.
Write a program that determines the total maximal income obtained by the K workers.
Being the team's leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.
Write a program that determines the total maximal income obtained by the K workers.
Input
The input contains:
Input
N K
L1 P1 S1
L2 P2 S2
...
LK PK SK
Semnification
N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i
Input
N K
L1 P1 S1
L2 P2 S2
...
LK PK SK
Semnification
N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i
Output
The output contains a single integer, the total maximal income.
Sample Input
8 4 3 2 2 3 2 3 3 3 5 1 1 7
Sample Output
17
Hint
Explanation of the sample:
the worker 1 paints the interval [1, 2];
the worker 2 paints the interval [3, 4];
the worker 3 paints the interval [5, 7];
the worker 4 does not paint any plank
the worker 1 paints the interval [1, 2];
the worker 2 paints the interval [3, 4];
the worker 3 paints the interval [5, 7];
the worker 4 does not paint any plank
Source
Romania OI 2002
题意:给你一个长度为n的木板,有k个工人,每个工人有一个工作点,最大工作范围和费用,工作点必须被包含在工作范围内,问你这n个工人能得到的最大费用是多少。
分析:f[i][j]表示前i个工人刷到j能的到最大费用,随着j的增大,f[i][j]的决策区间也在不断右移,可以用单调队列优化。
题意:给你一个长度为n的木板,有k个工人,每个工人有一个工作点,最大工作范围和费用,工作点必须被包含在工作范围内,问你这n个工人能得到的最大费用是多少。
分析:f[i][j]表示前i个工人刷到j能的到最大费用,随着j的增大,f[i][j]的决策区间也在不断右移,可以用单调队列优化。
#include <queue>
#include <vector>
#include <cstdio>
#include <utility>
#include <cstring>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
struct thing
{
int l,p,s;
friend bool operator < (thing a,thing b)
{
return a.s < b.s;
}
}a[105];
int n,k,f[105][16005];
int main()
{
cin.sync_with_stdio(false);
cin>>n>>k;
for(int i = 1;i <= k;i++) cin>>a[i].l>>a[i].p>>a[i].s;
sort(a+1,a+1+k);
memset(f,0,sizeof(f));
for(int i = 1;i <= k;i++)
{
deque <int>q;
for(int j = 0;j <= n;j++)
{
if(j < a[i].s)
{
while(!q.empty() && f[i-1][q.back()]-q.back()*a[i].p <= f[i-1][j]-j*a[i].p) q.pop_back();
q.push_back(j);
}
f[i][j] = f[i-1][j];
if(j >= a[i].s && j-a[i].s+1 <= a[i].l)
{
while(!q.empty() && j-q.front() > a[i].l) q.pop_front();
f[i][j] = max(f[i][j],f[i-1][q.front()] + (j-q.front())*a[i].p);
}
if(j != 0) f[i][j] = max(f[i][j-1],f[i][j]);
}
}
cout<<f[k][n];
}