Coin Change
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15568 Accepted Submission(s): 5263
Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
Sample Input
11 26
Sample Output
4 13
Author
Lily
Source
Recommend
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
int a[5] = {1,5,10,25,50};
const int maxn = 300;
const int maxnums = 100;
int dp[maxn][110]; // dp[i][j] 表示的是货币总额恰好为i时候 并且所用货币种类数小于等于j 的方案总数
int main()
{
memset(dp,0,sizeof(dp));
for(int i=0;i<=100;i++)
{
dp[0][i] = 1;
}
for(int i=0;i<5;i++)
{
<span style="color:#ff0000;">for(int j=a[i];j<=300;j++)</span>
{
<span style="color:#ff0000;">for(int k=1;k<=100;k++) 可以互换位置只要i在外面就可以了</span>
{
dp[j][k] += dp[j-a[i]][k-1] ;
}
}
}
// dp[j][k] = dp[j-a[i]][k-1] + a[i]; // j从小到大 k从小到大 i在最外面
int x;
while(scanf("%d",&x) != EOF)
{
printf("%d\n",dp[x][100]);
}
return 0;
}