A Knight's Journey
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 32782 | Accepted: 11154 |
Description

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
题意:
给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径。
经典的“骑士游历”问题,DFS水题一道
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node{
int x;
int y;
}Map[26*26+1];
int vis[27][27];
int flag;
int n,m;
int dx[]={-2,-2,-1,-1,1,1,2,2};
int dy[]={-1,1,-2,2,-2,2,-1,1};
int ok(int x,int y){
if(x>=0&&y>=0&&x<m&&y<n&&!vis[x][y]){
return 1;
}
return 0;
}
void dfs(int x,int y,int step){
Map[step].x=x;
Map[step].y=y;
if(step==m*n-1){
flag=1;
return ;
}
for(int i=0;i<8;i++){
if( ok( x+dx[i],y+dy[i] ) ){
vis[ x+dx[i] ][ y+dy[i] ]=1;
dfs(x+dx[i],y+dy[i],step+1);
if(flag)
return ;
vis[ x+dx[i] ][ y+dy[i] ]=0;
}
}
}
int main(){
int T;
scanf("%d",&T);
for(int kk=1;kk<=T;kk++){
printf("Scenario #%d:\n",kk);
scanf("%d%d",&n,&m);
memset(vis,0,sizeof(vis));
for(int i=0;i<m;i++){
for(int j=0;j<n;j++){
vis[i][j]=1;
flag=0;
dfs(i,j,0);
if(flag)
break;
}
if(flag)
break;
}
if(!flag){
printf("impossible\n\n");
}
else{
for(int i=0;i<m*n;i++){
printf("%c%d",Map[i].x+'A',Map[i].y+1);
}
cout<<endl<<endl;
}
}
return 0;
}