Cube Stacking
Time Limit: 2000MS | Memory Limit: 30000K | |
Total Submissions: 19073 | Accepted: 6644 | |
Case Time Limit: 1000MS |
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
Sample Output
1 0 2
题意: John和Betsy用N个完全相同的立方体玩游戏,John让Betsy完成P步操作,操作分为两种:
1.移动操作(
M
),移动含立方体
X
所在的堆加到
Y
所在的堆上头;
2.计数操作(
C
),计算立方体
X
下的立方体的个数,并输出;
分析:带权并查集。用三个数组,一个数组储存该树的总长度;另外一个数组储存该立方体X离根节点的长度; 还有一个数组储存立方体X的根节点;
#include <stdio.h>
#include <string.h>
int father[30010];//储存根节点
int dis[30010]; //记录以该节点为根的树的总节点数
int cnt[30010]; //记录该节点与根节点的距离
int find(int x)//查根并加权
{
if(x!=father[x])
{
int ans=father[x];
father[x]=find(father[x]);
cnt[x]=cnt[x]+cnt[ans];
//x与x的父亲的距离加上
//现在父亲与其“顶头上司”的距离
}
return father[x];
}
int main()
{
int n;
char a[2];
int b,c,x,y;
scanf("%d",&n);
for(int i=0;i<=30000;i++)//初始化
{
father[i]=i;
dis[i]=1;
cnt[i]=0;
}
while(n--)
{
scanf("%s",&a);
if(a[0]=='M')
{
scanf("%d%d",&b,&c);
x=find(b);
y=find(c);
if(x!=y)//合并树
{
father[y]=x;//将x作为y的根节点
cnt[y]+=dis[x];//因为x所在的堆要放在y上
dis[x]+=dis[y];//将y上的节点数赋给x(进行更新)
}
}
else
{
scanf("%d",&b);
x=find(b);
printf("%d\n",dis[x]-cnt[b]-1);
}
}
return 0;
}