108 - Maximum Sum
Time limit: 3.000 seconds
Background
A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.
The Problem
Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size or greater located within the whole array. As an example, the maximal sub-rectangle of the array:
is in the lower-left-hand corner:
and has the sum of 15.
Input and Output
The input consists of an array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by
integers separated by white-space (newlines and spaces). These
integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [-127, 127].
The output is the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
Sample Output
15
UVa 507的升级版。
测试数据又有问题。。就算你不满足“A sub-rectangle is any contiguous sub-array of size or greater located within the whole array”(子矩阵不能为零矩阵,但由于测试数据太弱可以为零矩阵)也能AC。
正确的代码:
/*0.015s*/
#include<cstdio>
#include<algorithm>
using namespace std;
int num[105][105];
int main(void)
{
int n, temp, maxn;
while (~scanf("%d", &n))
{
for (int i = 1; i <= n; ++i)
for (int j = 1; j <= n; ++j)
{
scanf("%d", &num[i][j]);
num[i][j] += num[i - 1][j]; ///累加每一列,越往下累加的数越多
}
maxn = num[1][1];
///从上往下,从左往右
for (int i = 1; i <= n; ++i)
for (int j = i; j <= n; ++j)///j从i开始
{
temp = 0;
for (int k = 1; k <= n; ++k)
{
if (temp >= 0) temp += num[j][k] - num[i - 1][k];
else temp = num[j][k] - num[i - 1][k];
maxn = max(maxn, temp);
}
}
printf("%d\n", maxn);
}
return 0;
}