UVa 10025 The ? 1 ? 2 ? ... ? n = k problem (数学&想法题&常数算法)

10025 - The ? 1 ? 2 ? ... ? n = k problem

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=99&page=show_problem&problem=966

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701

首先,1~n的和sum一定要>=k。当sum >n时要减掉一个数, 比如在数字a前面加个-号, 相当于sum - 2 * a,也就是说每次减掉只能是偶数,那么就要求sum % 2 == k % 2.(负数同理)


O(√k)代码:

/*0.006s*/

#include<cstdio>
#include<algorithm>
using namespace std;

int main(void)
{
	int T, k, sum, i;
	bool flag = false;
	scanf("%d", &T);
	while (T--)
	{
		if (flag)
			putchar('\n');
		else
			flag = true;
		scanf("%d", &k);
		k = abs(k), sum = 0;
		for (i = 1;; i++)
		{
			sum += i;
			if (sum >= k && ((sum - k) & 1) == 0)
			{
				printf("%d\n", i);
				break;
			}
		}
	}
	return 0;
}

O(1)代码:

/*0.006s*/

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int main(void)
{
	int T, k, n;
	bool flag = false;
	scanf("%d", &T);
	while (T--)
	{
		if (flag)
			putchar('\n');
		else
			flag = true;
		scanf("%d", &k);
		if (k == 0)
			puts("3");
		else
		{
			k = abs(k);
			n = (int)ceil((sqrt(0.25 + (k << 1)) - 0.5));
			if (k & 1)
			{
				if (n % 4 == 0 || n % 4 == 3)
					n = ((n + 1) >> 2 << 2) + 1;
			}
			else
			{
				if (n % 4 == 1 || n % 4 == 2)
					n = (n >> 2 << 2) + 3;
			}
			printf("%d\n", n);
		}
	}
	return 0;
}

UVA133-The Dole Queue问是一个典型的队列操作问,它要求处理一个动态变化的队列,模拟救济金发放的过程。为了解决这一问,我们需要熟练掌握队列的基本操作:入队(enqueue)、出队(dequeue)、查看队首(peek)等。通过编程实现这些操作,并处理特定的业务逻辑,比如在不同情况下向队列添加或移除人员。下面是一些具体的实现步骤: 参考资源链接:[掌握算法技巧:UVA133救济金发放问详解](https://wenku.csdn.net/doc/20610tuj1w?spm=1055.2569.3001.10343) 1. 定义队列:可以选择使用数组或链表来实现队列。数组实现简单但空间固定,链表实现复杂一些但更加灵活。 2. 入队操作:每当有新的申请者到来时,将该申请者加入到队列尾部。如果是数组实现,需要检查数组是否已满;如果是链表实现,只需创建一个新节点并将其连接到链表尾部。 3. 出队操作:每当有人员领取救济金后,将其从队列头部移除。这通常意味着修改链表头部指针或更新数组索引。 4. 处理特殊情况:例如,目中可能会要求优先处理特定的人群,这需要在出队操作中加入条件判断,确保符合规则的人员先被服务。 5. 编写主程序:主程序需要不断地模拟时间的流逝,并根据当前时间处理各种事件,包括新申请者的到来和服务已排队人员。需要正确维护时间变量,并在每次事件处理后更新时间。 6. 调试与测试:在UVA平台上提交代码前,要确保程序能够处理所有可能的情况,并且没有逻辑错误。对于复杂的业务逻辑,可能需要使用一些调试技巧,如打印日志来帮助分析程序流程。 通过以上步骤,你可以构建一个能够解决UVA133-The Dole Queue问的程序。为了更深入地理解队列数据结构及其在算法中的应用,建议阅读《掌握算法技巧:UVA133救济金发放问详解》。这本书不仅提供了UVA133目的详细解析和算法实现,还涵盖了队列数据结构的更多应用和编程技巧,是算法学习者的宝贵资源。 参考资源链接:[掌握算法技巧:UVA133救济金发放问详解](https://wenku.csdn.net/doc/20610tuj1w?spm=1055.2569.3001.10343)
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值