POJ 2479 Maximum sum (DP&双最大子段和)

Maximum sum

Time Limit:  1000MS
Memory Limit: 65536K

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

首先,由于要求左右两段,必须把左边最大子段和的右端点从1~n遍历下,求每个值对应的最大子段和;右边从n~1遍历。
每部分最大子段和由转移方程left[i] = max(left[i - 1] + v[i], v[i])给出。
最后,求left[i - 1] + right[i]的最大值。(充分利用左右两部分的范围)

完整代码:
/*422ms,704KB*/

#include <cstdio>
#include <algorithm>
using namespace std;

int v[50001], left[50001], right[50001];

int main(void)
{
	int icase;
	scanf("%d", &icase);
	while (icase--)
	{
		int size;
		scanf("%d", &size);
		for (int i = 0; i < size; ++i)
			scanf("%d", &v[i]);
			
		left[0] = v[0];
		for (int i = 1; i < size; ++i)
			left[i] = max(left[i - 1] + v[i], v[i]);
		for (int i = 1; i < size; ++i)
			left[i] = max(left[i], left[i - 1]);
			
		right[size - 1] = v[size - 1];
		for (int i = size - 2; i >= 0; --i)
			right[i] = max(right[i + 1] + v[i], v[i]);
		for (int i = size - 2; i >= 0; i--)
			right[i] = max(right[i], right[i + 1]);
			
		int res = left[0] + right[1];
		for (int i = 2; i < size; ++i)
			res = max(res, left[i - 1] + right[i]);
		printf("%d\n", res);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值