ACM: uva 11584 -

本文介绍了一种算法,用于解决字符串的最小回文子串划分问题。通过动态规划的方法,实现了一个时间复杂度为O(n^3)的解决方案,并进一步优化至O(n^2)。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem H: Partitioning by Palindromes

We say a sequence of characters is a palindromeif it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

ACM: <wbr>uva <wbr>11584 <wbr>-



partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3

racecar

fastcar

aaadbccb

Sample Output

1

7

3

 

题意: 将一段字符串划分为尽可能少的回文串, 输出最少能划分为多少个回文串.

 

解题思路:

      1. 简单DP, 最朴素的做法就是枚举起点和终点, 判断这段是否为回文串, 时间复杂度O(n^3);

         方程:  dp[i] = min(dp[i], dp[j-1]+1)  (j->i是回文串);

         dp[i]表示: 前i个字符最少可以组成多少个回文串.

      2. 还有方法可以缩小时间复杂度, 就是直接判断j->i是否是回文串, 时间复杂度O(n^2);

         可以设flag[i][j]: 以str[j]开始的长度为i的字符串是否为回文串.

 

代码:

O(n^3)

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 1005
const int INF = (1<<29);

int n;
int dp[MAX];
char str[MAX];

inline int min(int a, int b)
{
 return a < b ? a : b;
}

bool judge(int left, int right)
{
 for(int i = left, j = right; i <= j; ++i, --j)
  if( str[i] != str[j] ) return false;
 return true;
}

int main()
{
// freopen("input.txt", "r", stdin);
 scanf("%d", &n);
 int i, j;
 while(n--)
 {
  scanf("%s", str+1);
  int len = strlen(str+1);
  for(i = 1; i <= len; ++i)
   dp[i] = INF;

  dp[0] = 0;
  for(i = 1; i <= len; ++i)
  {
   for(j = 1; j <= i; ++j)
   {
    if( judge(j, i) )
     dp[i] = min(dp[i], dp[j-1]+1);
   }
  }

  printf("%d\n", dp[len]);
 }

 return 0;
}

 

O(n^2)

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 1005
const int INF = (1<<29);

char str[MAX];
int dp[MAX];
bool flag[MAX][MAX]; //flag[i][j]: 长度为i, 从str[j]开始有一段回文串

inline int min(int a, int b)
{
 return a < b ? a : b;
}

void init(int len)
{
 memset(flag, false, sizeof(flag));
 int i, j;
 for(i = 1; i <= len; ++i) flag[1][i] = true;
 if(len == 1) return ;

 for(i = 1; i <= len-1; ++i)
  if(str[i] == str[i+1])
   flag[2][i] =  true;
 for(i = 3; i <= len; ++i)
 {
  for(j = 1; j <= len-i+1; ++j)
  {
   if(flag[i-2][j+1] && str[j] == str[j+i-1])
    flag[i][j] = true;
  }
 }
}

int main()
{
// freopen("input.txt", "r", stdin);
 int caseNum, i, j;
 scanf("%d", &caseNum);
 while(caseNum--)
 {
  scanf("%s", str+1);
  int len = strlen(str+1);
  init(len);

  for(i = 1; i <= len; ++i) dp[i] = INF;
  dp[0] = 0;
  for(i = 1; i <= len; ++i)
  {
   for(j = 1; j <= i; ++j)
   {
    if( flag[j][i-j+1] )
     dp[i] = min(dp[i], dp[i-j]+1);
   }
  }
  printf("%d\n", dp[len]);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值