Boys vs Girls(PAT A 1036)

这篇博客介绍了一个程序设计竞赛的问题,即找出所有男性学生中最低分和女性学生中最高分的差异。输入包含学生姓名、性别、ID和成绩,输出最高分女性和最低分男性的信息及分数差距。提供的C++代码实现了该功能,能处理不同数量的学生数据,并在缺少某一性别数据时给出相应提示。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

分数值:25分
通过率:43%


1. 问题描述

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference g r a d e ​ ​ F − g r a d e ​ M grade​​_F−grade​_M gradeFgradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

2. 代码参考(C++)

#include <cstdio>

struct person{
	char name[11];
	char id[11];
	int score;
}M, F, temp;

void init(){
	M.score = 101;
	F.score = -1;
}

int main(){
	init();
	int n;
	char gender;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%s %c %s %d", temp.name, &gender, temp.id, &temp.score);
		if(gender == 'M' && temp.score < M.score)
			M = temp;
		else if(gender == 'F' && temp.score > F.score)
			F = temp;
	}
	if(F.score == -1)
		printf("Absent\n");
	else
		printf("%s %s\n", F.name, F.id);
	if(M.score == 101)
		printf("Absent\n");
	else
		printf("%s %s\n", M.name, M.id);
	if(F.score == -1 || M.score == 101)
		printf("NA\n");
	else 
		printf("%d\n", F.score - M.score);
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值