1142 Maximal Clique (25分)
作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB
A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.
Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.
Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
题意:
给一张无向连通图,若一个集合中任意两点都相通则它就是个环,若没有其他任何点能插入这个环中(即还有其他点插入也能使得它是个环)那么这个集合就是最大的环。要求判断所给集合是否是最大的环或是否是环。
思路:
创建邻接矩阵来保存无向图信息。首先通过遍历判断是否两两相通,在遍历所有不是集合中的点是否能与所给的点都相通。这是道很傻的遍历题。
参考代码:
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 205;
int G[maxn][maxn] = {0};
int main() {
int nv, ne, a, b, m, k;
scanf("%d%d", &nv, &ne);
for (int i = 0; i < ne; i++) {
scanf("%d%d", &a, &b);
G[a][b] = G[b][a] = 1;
}
scanf("%d", &m);
for (int i = 0; i < m; i++) {
scanf("%d", &k);
vector<int> v(k);
bool flag = 0;
for (int j = 0; j < k; j++)scanf("%d", &v[j]);
for (int j = 0; j < k - 1; j++) {
for (int t = j + 1; t < k; t++)
if (G[v[j]][v[t]] == 0)flag = 1;
}
if (flag) {
printf("Not a Clique\n");
continue;
}
for (int j = 1; j <= nv; j++) {
int cnt = 0;
if (find(v.begin(), v.end(), j) == v.end()) {
for (int t = 0; t < k; t++)
if (G[j][v[t]] == 1)cnt++;
}
if (cnt == k) {
flag = 1;
break;
}
}
if (flag)printf("Not Maximal\n");
else printf("Yes\n");
}
return 0;
}
如有错误,欢迎指正