1106 Lowest Price in Supply Chain(25 分)
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki ID[1] ID[2] ... ID[Ki]
where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2
作者: CHEN, Yue
单位: 浙江大学
时间限制: 250 ms
内存限制: 64 MB
代码长度限制: 16 KB
题目大意:同供应链问题,这次要求你给出价格最低的零售商,并给出零售商的数量,其实就是求出深度最小的叶节点,然后按照给定的规则计算出价格
解题思路:还是两种,DFS遍历路径,设一个level和一个minlevel,先把minlevel初始化为maxn,每当找到比minlevel更小的level,且这个结点是叶节点的时候,更新minlevel,把用于记录minlevel叶节点数量的num置1,如果遇到等于minlevel的叶节点,就把num++,最后我们根据minlevel可以计算出价格,然后输出价格和num就可以了。第二种解法层序遍历也是同样的思路
AC代码:
#include<iostream>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<algorithm>
#include<cmath>
using namespace std;
int n;
double price,rate;
const int maxn=100010;
struct node{
int level;
vector<int> child;
}chain[maxn];
void levelorder(int root);
int num=0;
double ans;
int minlevel=maxn;
int main()
{
cin>>n>>price>>rate;
int k,child;
rate=rate/100;
for(int i=0;i<n;i++)//建树
{
cin>>k;
for(int j=0;j<k;j++)
{
cin>>child;
chain[i].child.push_back(child);
}
}
levelorder(0);
printf("%.4f %d",ans,num);
return 0;
}
void levelorder(int root)
{
queue<int> q;
q.push(root);
chain[root].level=0;//根节点高度设为0
int level=chain[root].level;//level为当前访问结点层次
while(!q.empty())
{
int top=q.front();
q.pop();
if(chain[top].child.size()==0)
{
level=chain[top].level;
if(level<minlevel)
{
num=1;
minlevel=level;
}
else if(level==minlevel)
num++;
}
for(int i=0;i<chain[top].child.size();i++)
{
int child=chain[top].child[i];
q.push(child);
chain[child].level=chain[top].level+1;
}
}
rate=pow(1+rate,minlevel);
ans=price*rate;
}