快速排序确定枢轴

该博客讨论了快速排序算法中的分区过程,重点在于如何确定合适的枢轴元素。通过维护左右边界的最大值和最小值,可以找出可能的枢轴候选。在给定的示例中,对于输入序列1, 3, 2, 4, 5,有3个元素可以作为枢轴。代码实现中使用了两个数组记录左右边界信息,并输出了符合条件的枢轴元素。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

问题

1101 Quick Sort (25 分)
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
5
). Then the next line contains N distinct positive integers no larger than 10
9
. The numbers in a line are separated by spaces.

Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

思路

还是两个数组LMax[],RMin[]分别记录该位置,左边的最大值和右边的最小值,只要满足左边最大值小于该元素,右边最小值大于该元素,那么该元素就是枢轴元素。注意MAX和MIN初始化赋值一个是0,一个是无穷大。

代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100010;
const int INF = 1000000000;
vector<int> seq;
vector<int> ans;
int LMax[maxn],RMin[maxn],MAX = 0,MIN = INF;
int main(){
    int n,temp;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        seq.push_back(temp);
    }
    for (int j = 0; j < n; ++j) {
        LMax[j] = MAX;
        if(seq[j]>MAX){
            MAX = seq[j];
        }
    }
    for (int j = n-1; j >= 0; --j) {
        RMin[j] = MIN;
        if(seq[j]<MIN){
            MIN = seq[j];
        }
    }
    for (int k = 0; k < n; ++k) {
        if(LMax[k]<seq[k] && seq[k]<RMin[k])
            ans.push_back(seq[k]);
    }
    sort(ans.begin(),ans.end());
    cout<<ans.size()<<endl;
    for (int l = 0; l < ans.size(); ++l) {
        cout<<ans[l];
        if(l!=ans.size()-1)
            cout<<" ";
    }
    cout<<endl;
    return 0;
}

总结

return前面的回车一定要加,不然会格式错误,太坑了啊。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值