Largest Rectangle in a Histogram
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 16277 | Accepted: 5261 |
Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer
n, denoting the number of rectangles it is composed of. You may assume that
1<=n<=100000. Then follow
n integers
h1,...,hn, where
0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is
1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
Sample Output
8 4000
Hint
Huge input, scanf is recommended.
Source
题目大意:
柱状图是由一些宽度相等的长方形下端对齐后横向排列得到的图形。现在有由n个宽度为1,高度分别为h1,h2,…,hn的长方形从左到右依次排列组成的柱状图。问里面包含的长方形的最大面积是多少。
大致思路:
单调栈的经典应用。这道题从数据来看暴力明显是过不了的。很容易想到,我们可以枚举每一个柱为最小高度时向左向右扩展能得到的长方形的最大面积,现在问题是如何高效求解每一个柱的最左端和最右端。我们把这两个值分别表示为L[i]和R[i](左闭右开),则
L[i] = ( j<=i 并且 h[j-1]<h[i] 的最大的j )
R[i] = ( j>i 并且 h[j]<h[i] 的最小的j )
如果能求出L[i]和R[i],那么最大的面积就是max{h[i]*(R[i]-L[i]) | 0<=i<n}。
而L和R可以使用栈非常高效地求解(O(n))。原理我也说不清(其实是我不会,逃
如果不懂可以看代码然后一步步模拟就明白了,当然最根本的原理或者说是如何想出这种解法的就不知道了(我感觉这挺重要的,可是并没有搜到23333
//Largest Rectangle in a Histogram.cpp -- poj 2559
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <queue>
#include <map>
using namespace std;
typedef long long ll;
const int maxn = 100000 + 10;
ll h[maxn];
int L[maxn], R[maxn];
int s[maxn], n;
void solve()
{
int t = 0;
for( int i=0; i<n; ++i )
{
while( t>0 && h[i]<=h[s[t-1]] ) --t;
L[i] = t==0 ? 0 : s[t-1] + 1;
s[t++] = i;
}
t = 0;
for( int i=n-1; i>=0; --i )
{
while( t>0 && h[i]<=h[s[t-1]] ) --t;
R[i] = t==0 ? n : s[t-1];
s[t++] = i;
}
}
int main()
{
while( ~scanf("%d", &n) && n )
{
ll Max = 0;
for( int i=0; i<n; ++i )
scanf("%I64d", &h[i]);
solve();
for( int i=0; i<n; ++i )
{
Max = max(h[i]*(R[i]-L[i]), Max);
}
printf("%I64d\n", Max);
}
return 0;
}