Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7851 | Accepted: 2511 |
Description
Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.
A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.
Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.
Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.
Sample Input
5 1 8 8 8 1
Sample Output
2
Source
题目大意:
为了准备考试,Jessica开始读一本很厚的课本。要想通过考试,必须把课本中所有的知识点都掌握。这本书总共有P页,第i页恰好有一个知识点ai(每个知识点都有一个整数编号)。全书中同一个知识点可能会被多次提到,所以她希望通过阅读其中连续的一些页把所有的知识点都覆盖到。给定每页写到的知识点,请求出要阅读的最少页数。
大致思路:
“我们假设从某一页s开始阅读,为了覆盖所有的知识点需要阅读到t。这样的话可以知道如果从s+1开始阅读的话,那么必须阅读到t’> t页为止。由此这题也可以用尺取法。”(ps:反复地推进区间的开头和末尾,来求满足条件的最小区间的方法被称为尺取法。)
这里要注意一点,由于知识点ai的数据范围题目只是说不会超过32位int。也就是ai最大可能为2147483647。所以你在去重算总数以及记录每个知识点在这个区间出现的次数时用普通的数组标记是行不通的。这时STL就有很大作用了,我们可以用set来去重算总数,再用map来标记在某区间上知识点出现的次数就可以了。
AC代码:
//Jessica's Reading Problem.cpp -- poj 3320
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <queue>
#include <map>
#include <set>
using namespace std;
typedef long long ll;
const int maxn = 1000000 + 10;
int p[maxn];
int main()
{
int n;
while( ~scanf("%d", &n) )
{
set<int> stal;
for( int i=0; i<n; ++i )
{
scanf("%d", &p[i]);
stal.insert(p[i]);
}
int sum = stal.size();
int s = 0, t = 0, len = n, ans = 0;
map<int, int> mp;
while( true )
{
while( t<n && ans<sum )
{
if( !mp[p[t]] )
ans++;
mp[p[t++]]++;
}
if( ans<sum ) break;
len = min(len, t-s);
--mp[p[s]];
if( !mp[p[s++]] )
--ans;
}
printf("%d\n", len);
}
return 0;
}