2016多校训练Contest6: 1001 A Boring Question hdu5793


Problem Description
There are an equation.
0k1,k2,kmn1j<m(kj+1kj)%1000000007=?
We define that  (kj+1kj)=kj+1!kj!(kj+1kj)!  . And  (kj+1kj)=0  while  kj+1<kj .
You have to get the answer for each  n  and  m  that given to you.
For example,if  n=1 , m=3 ,
When  k1=0,k2=0,k3=0,(k2k1)(k3k2)=1 ;
When k1=0,k2=1,k3=0,(k2k1)(k3k2)=0 ;
When k1=1,k2=0,k3=0,(k2k1)(k3k2)=0 ;
When k1=1,k2=1,k3=0,(k2k1)(k3k2)=0 ;
When k1=0,k2=0,k3=1,(k2k1)(k3k2)=1 ;
When k1=0,k2=1,k3=1,(k2k1)(k3k2)=1 ;
When k1=1,k2=0,k3=1,(k2k1)(k3k2)=0 ;
When k1=1,k2=1,k3=1,(k2k1)(k3k2)=1 .
So the answer is 4.
 

Input
The first line of the input contains the only integer  T , (1T10000)
Then  T  lines follow,the i-th line contains two integers  n , m , (0n109,2m109)
 

Output
For each  n  and  m ,output the answer in a single line.
 

Sample Input
  
  
2 1 2 2 3
 

Sample Output
  
  
3 13

直接搬运原题的题解了。。


以上。。似乎第三步和第四步是一样的

倒数第二步用二项式定理就可以推出来了

#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
long long mod=1000000007;
inline long long power(long long x,int y)
{
	long long xt=1;
	while(y!=0)
	{
		if(y%2==1)
			xt=xt*x%mod;
		x=x*x%mod;
		y/=2;
	}
	return xt;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T>0)
	{
		T--;
		int n,m;
		scanf("%d%d",&n,&m);
		printf("%I64d\n",(power(m,n+1)+mod-(long long)1)*power(m-1,mod-2)%mod);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值