非常可乐 HDU - 1495
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0)zhe 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3
这题本来用dfs做,遍历所有结果求出最小值,但错了。于是改为bfs,刚开始做的是用i来判断6种情况,特麻烦,写完后还有bug,百度了代码,见别人用两个for循环来表示每种情况,确实妙。又学到了一个方法。
见代码:
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int c[3];
int n,m,ans;
bool vis[105][105][105];
int half;
struct node{
int b[3];
int step;
};
void bfs()
{
node cur,next;
queue<node>q;
cur.b[0]=c[0];
cur.b[1]=0;
cur.b[2]=0;
cur.step=0;
q.push(cur);
vis[c[0]][0][0]=true;
while(!q.empty())
{
cur=q.front();
q.pop();
for(int i=0;i<3;i++)
{
if(cur.b[i]>0)
for(int j=0;j<3;j++)//第i个杯子向第j个杯子倒水
{
next=cur;
if(i==j) continue;
if(next.b[i]>(c[j]-next.b[j]))//若能倒满
{
next.b[i]-=c[j]-next.b[j];
next.b[j]=c[j];
}
else//倒不满
{
next.b[j]+=next.b[i];
next.b[i]=0;
}
if(!vis[next.b[0]][next.b[1]][next.b[2]])
{
vis[next.b[0]][next.b[1]][next.b[2]]=true;
next.step=cur.step+1;
if((next.b[0]==half&&next.b[1]==half)||(next.b[0]==half&&next.b[2]==half)||(next.b[1]==half&&next.b[2]==half))
{
cout<<next.step<<endl;
return;
}
q.push(next);
}
}
}
}
cout<<"NO"<<endl;
return;
}
int main()
{
while(cin>>c[0]>>c[1]>>c[2],c[0]+c[1]+c[2])
{
memset(vis,0,sizeof(vis));
half=c[0]/2;
if(c[0]%2!=0)
{
cout<<"NO"<<endl;
}
else
bfs();
}
return 0;
}