POJ 1338 Ugly Numbers(丑数)

Ugly Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22726 Accepted: 10127

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

分析:丑数是指因子只有2、3、5的数。

也就是说丑数的因子都是由2、3、5组成的,每个数的2、3、5的个数不同就组成了不同的数。

用x表示2的个数,y表示3的个数,z表示5的个数,每个数字之前的丑数,乘上2、3、5都形成新的丑数。

别人清楚的分析如下:

思路:用一个长度为1500的数组存储这些数,另有三个游标x,y,z;

a[1]=1,x=y=z=1,代表第一个数为1,此后的数都是通过已有的数乘以2,3,5得到的,

那么x,y,z分别代表a[x],a[y],a[z]可以通过乘以2,3,5来得到新的数,i递增,每次取2*a[x], 3*a[y], 5*a[z]

中的最小值,得到a[i]后,可以将对应的x(或y,z)右移,当然如果原本通过3*2得到6,那么2*3也能得到6,

因此可能x和y都需要递增。

代码如下:
#include <stdio.h>
#include <string.h>
int pri[1510];
int min(int x,int y,int z)
{
	int min=x;
	min = (min > y) ? y:min;
	min = (min > z) ? z:min;
	return min;
}
int main()
{
	int i,j;
	int x,y,z;
	int n;
	x=y=z=1;
	memset(pri,0,sizeof(pri));
	pri[1]=1;
	for(i=2;i<=1500;i++)
	{
		pri[i] = min(2*pri[x],3*pri[y],5*pri[z]);
		if(pri[i] == 2*pri[x])
			x++;
		if(pri[i] == 3*pri[y])
			y++;
		if(pri[i] == 5*pri[z])
			z++; 
	}
	while(scanf("%d",&n),n)
	{
		printf("%d\n",pri[n]);
	}
		
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值