I - Wormholes POJ - 3259

本文探讨了在一个包含常规路径和特殊虫洞的农场环境中,是否存在一种路径使得 Farmer John 能够实现时间旅行并回到起点的时间点之前。通过构建图论模型,并采用 Bellman-Ford 算法检测潜在的负权环,来判断这种时间旅行的可能性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b花费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从第i个点开始走,能不能回到i花的时间为负

题解:其实给出了坐标,这个时候就可以构成一张图,然后将回到从前理解为是否会出现负权环,用bellman-ford就可以解出了

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,m,h;
int dis[6000];
int s=0;
struct point
{
    int l,r,s;
} a[6000];
int fin()
{
    dis[1]=0;
    for(int i=1; i<n-1; i++)
    {
        for(int j=1; j<=s; j++)
        {
            if(dis[a[j].r]>dis[a[j].l]+a[j].s)
                dis[a[j].r]=dis[a[j].l]+a[j].s;
        }
    }
    for(int j=1; j<=s; j++)
        if(dis[a[j].r]>dis[a[j].l]+a[j].s)
            return 0;
    return 1;
}
int main()
{
    int t;
    cin>>t;
    for(int i=1; i<=t; i++)
    {
        memset(dis,10003,sizeof(dis));
        memset(a,0,sizeof(a));
        s=0;
        cin>>n>>m>>h;

        for(int j=1; j<=m; j++)
        {
            int z1,z2,z3;
            cin>>z1>>z2>>z3;
            a[++s].l=z1;
            a[s].r=z2;
            a[s].s=z3;
            a[++s].l=z2;
            a[s].r=z1;
            a[s].s=z3;

        }
        for(int j=1; j<=h; j++)
        {
            int z1,z2,z3;
            cin>>z1>>z2>>z3;
            a[++s].l=z1;
            a[s].r=z2;
            a[s].s=-z3;
        }
        int pp=fin();
        if(pp==1)cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值