问题描述:
Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 42056 Accepted: 17526
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
题目大意:
给出一个字符串,求出该串有多少个最小周期串。
解题思路:
求出字符串的最小周期串的长度,然后用给定字符串的长度除以最小周期串的长度即可。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1000005;
char a[maxn];
int main() {
while(scanf("%s", &a) != EOF) {
if(a[0] == '.')
break;
int l = strlen(a);
for(int j, i = 1; i <= l; i ++) {
if(l % i == 0) {
for(j = i; j < l; j ++) {
if(a[j] != a[j % i])
break;
}
if(j == l) {
cout << l / i << endl;
break;
}
}
}
}
return 0;
}