HDOJ 1525 Euclid's Game 博弈论

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1700    Accepted Submission(s): 751


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
  
  
34 12 15 24 0 0
 

Sample Output
  
  
Stan wins Ollie wins
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1524  1404  1517  1527  1729 
 

分两种情况讨论:
如果输入的两个数a>b有 a>2b 则先手必胜
小于的话b 和 a-b 在进行如上的判断,先后手转换。
用递归解决,非常清晰明了。

#include <iostream>
using namespace std;
int main()
{
	ios::sync_with_stdio(false);
	int a,b,flag;
	while (cin>>a>>b && (a || b)){
		flag=1;
		while (1){
			if (a<b) swap(a,b);
			if ((a/b>=2) || (a%b==0) || (b==0)){
				if (flag)
					cout<<"Stan wins\n";
				else
					cout<<"Ollie wins\n";
				break;
			}
			a-=b;	
			flag^=1;
		}
	}
	return 0;
} 

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.youkuaiyun.com/kdwycz


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值