POJ-1456 Supermarket (贪心)

Supermarket
http://poj.org/problem?id=1456
Time Limit: 2000MS Memory Limit: 65536K
   

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题目大意:有n种物品,每个物品有价格p和保质期d,每天只能卖出一个未过期的物品,求商家最大能获得多少钱?

大致思路:贪心即可,每次挑选价格最高的物品,看在保质期内是否有未被占用的天,如果有在占用该天卖出该物品,否则找下一个即可。

可以用并查集的思想,更新离保质期最近的合法天

刚开始pre数组和vis数组初始化的范围不对,导致WA了很多次。

#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;

const int MAXN=10005;

struct Node {
    int p,d;

    Node(int pp=0,int dd=0):p(pp),d(dd) {}

    bool operator < (const Node& a) const {
        return p<a.p||(p==a.p&&d<a.d);
    }
}cur;

int n,ans;
int pre[MAXN],p,d,mxd;
bool vis[MAXN];
priority_queue<Node> q;

int getPre(int a) {
    if(vis[pre[a]]) {
        return pre[a]=getPre(pre[a]);
    }
    return pre[a];
}

int main() {
    while(scanf("%d",&n)==1) {
        ans=mxd=0;
        for(int i=1;i<=n;++i) {
            scanf("%d%d",&p,&d);
            q.push(Node(p,d));
            if(mxd<d) {
                mxd=d;
            }
        }
        vis[0]=false;
        for(int i=1;i<=mxd;++i) {
            pre[i]=i-1;
            vis[i]=false;
        }
        while(!q.empty()) {
            cur=q.top();
            q.pop();
            d=cur.d;
            if(vis[d]) {//如果第d天已经被占用,则在前面寻找可用天
                d=getPre(d);
            }
            if(d!=0) {
                ans+=cur.p;
                vis[d]=true;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值