Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 13728 | Accepted: 9724 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
Source
原题链接:http://poj.org/problem?id=3070
递推的式子一般都可以化成矩阵相乘的形式。关键的就是构造矩阵,
但这题题目已经构造好了,所以就成了模(shui)板(shu)题了。
AC代码:
/**
blog:http://blog.youkuaiyun.com/hurmishine
*/
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int mod= 10000;
LL n;
struct Mat
{
int m[2][2];
};
Mat P=
{
1,1,
1,0
};
Mat I=
{
1,0,
0,1
};
Mat mul (Mat x,Mat y)
{
Mat z;
for(int i=0; i<2; i++)
{
for(int j=0; j<2; j++)
{
z.m[i][j]=0;
for(int k=0; k<2; k++)
{
z.m[i][j]+=(x.m[i][k]*y.m[k][j])%mod;
z.m[i][j]%=mod;
}
}
}
return z;
}
Mat quick_Mod(Mat a,LL b)
{
Mat ans=I;
Mat tmp=a;
while(b>0)
{
if(b&1)
ans=mul(ans,tmp);
tmp=mul(tmp,tmp);
b>>=1;
}
return ans;
}
int main()
{
while(cin>>n)
{
if(n==-1) break;
Mat tmp=quick_Mod(P,n);
cout<<tmp.m[0][1]<<endl;
}
return 0;
}
尊重原创,转载请注明出处:http://blog.csdn.net/hurmishine