杭电acm1098
Ignatius's puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3894 Accepted Submission(s): 2608
Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".
no exists that a,then print "no".
Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
Sample Input
111009999
Sample Output
22no43
Author
eddy
题目中文意思:
一个函数: f(x)=5*x^13+13*x^5+k*a*x
给定一个非负的k值 ,求最小的非负的a值,(k, a 都是整型)使得对任意的整数x都能使f(x)被65整除。
每输入一个k 值 ,对应输出一个 a值 ,若a值不存在的话,则输出 no
解题思路:数学归纳法 f(x)=5*x^13+13*x^5+k*a*x
假设当x=n时 65|f(x)成立,那一定有 65|f(n+1)成立
那么65|f(n+1)-f(n) 成立 通过二项展开可以得到只要18+k*a可以被65整除就可以了
在1~65之间遍历就ok。
#include <stdio.h>
int main()
{
int a,k,sum;
while(scanf("%d",&k)!=EOF)
{
for(a=1;a<=65;a++)
{
sum = 18 + a*k;
if(sum%65 == 0)
break;
}
if(a == 66)
printf("no\n");
else
printf("%d\n",a);
}
return 0;
}