Given two sets of integers, the similarity of the sets is defined to be N~c~/N~t~*100%, where N~c~ is the number of distinct common numbers shared by the two sets, and N~t~ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=10^4^) and followed by M integers in the range [0, 10^9^]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
题意:求两个集合的交集与并集,计算相似度
思路:set_union,set_intersection
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <vector>
#include <sstream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e6+5;
set<int>st[55];
int main() {
int n,q,x,m,a,b;
scanf("%d",&n);
rep(i,0,n) {
scanf("%d",&m);
while(m--) {
scanf("%d",&x);
st[i].insert(x);
}
}
scanf("%d",&q);
while(q--) {
scanf("%d%d",&a,&b);
a--,b--;
vector<int>tot, same;
/**back_inserter(container):使用push_back()在容器尾端安插元素,元素排列顺序和安插顺序相同。
只有在提供了push_back()成员函数的容器才能使back_inserter(container)这样的容器有:vector,deque,list
set_union,set_intersection 集合的并集和交集运算
*/
set_union(st[a].begin(),st[a].end(),st[b].begin(),st[b].end(),back_inserter(tot));
set_intersection(st[a].begin(),st[a].end(),st[b].begin(),st[b].end(),back_inserter(same));
printf("%.1f%%\n",100.0*same.size()/tot.size());
}
return 0;
}
参考博客:
https://blog.youkuaiyun.com/tianxiaolu1175/article/details/48413163/
https://blog.youkuaiyun.com/cillyb/article/details/60993193
https://blog.youkuaiyun.com/xianyun2009/article/details/50354581