Binary String Matching
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
3
-
描述
- Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
-
输入
- The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A. 输出
- For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A. 样例输入
-
3 11 1001110110 101 110010010010001 1010 110100010101011
样例输出
-
3 0 3
三种方式:
1.KMP
#include<iostream>
#include<cstring>
using namespace std;
const int Max=1005;
char T[Max],S[Max];
int nex[Max];
int lenT,lenS;
void getNex(){
int j=nex[0]=-1;
int i=0;
while(i<lenT){
while(j!=-1&& T[i]!=T[j]) j=nex[j];
if(T[++i]==T[++j])
nex[i]=nex[j];
else
nex[i]=j;
}
}
int kmp(){
int ans=0;
getNex();
int j=0;
int i=0;
while(i<lenS){
while (j!=-1&&S[i]!=T[j]) j=nex[j];
i++,j++;
if(j>=lenT){
ans++;
j=nex[j];
}
}
return ans;
}
int main()
{
int n;
cin>>n;
while(n--){
memset(nex,0,sizeof(nex));
cin>>T>>S;
lenT=strlen(T);
lenS=strlen(S);
int ans=kmp();
cout<<ans<<endl;
}
return 0;
}
2.暴力
#include<iostream>
#include<cstring>
#include<string>
using namespace std;
char S[1005],T[1005];
int main()
{
int n;
cin>>n;
while(n--){
cin>>T>>S;
int lenT=strlen(T);
int lenS=strlen(S);
int flag=0;
int ans=0;
for(int i=0;i<lenS;i++){
flag=0;
for(int j=0;j<lenT;j++){
if(S[i+j]!=T[j]){
flag=1;
break;
}
}
if(!flag){
ans++;
}
}
cout<<ans<<endl;
}
return 0;
}
3.string库:
#include<iostream>
#include<string>
using namespace std;
string s,t;
int main()
{
int n;
cin>>n;
while(n--){
cin>>t>>s;
int len=0;
int ans=0;
while(len=s.find(t.c_str(),len),len!=string::npos){
len++;
ans++;
}
cout<<ans<<endl;
}
return 0;
}