Drainage Ditches
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 82240 | Accepted: 31942 |
Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
Input
The input includes several cases.
For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
Sample Output
50
题意:给你一个网络流最标准地图。。
解析:模版题,见注释。
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int inf = 0x7fffffff;
const int N = 1e3+10;
int n, m;
int pre[N];//增广路中一个点的前缀
bool vis[N];//增广路走过的点
int mp[N][N];//残余网络
bool bfs(int s,int e)
{
memset(vis,false,sizeof(vis));
memset(pre,-1,sizeof(pre));
vis[s] = true;
pre[s] = s;
queue<int>q;
q.push(s);
while(!q.empty())
{
int now = q.front();q.pop();
for(int i = 1; i <= n; i++)
{
if(mp[now][i] > 0&&!vis[i])//要有流量才能走
{
vis[i] = true;
pre[i] = now;
if(i == e) return true;//找到汇点说明有增广路
q.push(i);
}
}
}
return false;
}
int Edmonds_Karp(int s,int e)
{
int flow = 0, d;
while(bfs(s,e))
{
d = inf;
for(int i = e; i != s; i = pre[i])
d = min(d,mp[pre[i]][i]);
for(int i = e; i != s; i = pre[i])
{
mp[pre[i]][i] -= d;
mp[i][pre[i]] += d;//反向边
}
flow += d;
}
return flow;
}
int main()
{
while(~scanf("%d%d",&m,&n))
{
int s, e, c;
memset(mp,0,sizeof(mp));
for(int i = 1; i <= m; i++)
{
scanf("%d%d%d",&s,&e,&c);
mp[s][e] += c;
}
printf("%d\n",Edmonds_Karp(1,n));
}
return 0;
}