HDU 1542 [POJ 1151] Atlantis (矩形面积并)

解决一个算法问题,计算多个矩形叠加后的总面积。通过离散化和线段树技术实现精确计算,适用于竞赛编程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16139    Accepted Submission(s): 6598


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
  
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
  
  
Test case #1 Total explored area: 180.00
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1828  1255  1394  2795  1823 

题意:给你n个矩形,算他们叠在一起覆盖的面积和。

分析:由于矩形的坐标是浮点类型,为处理要先离散化成整数而后进行线段树的更新。

计算矩形面积的过程,最好自己在纸上多画一画就清楚了。


ps:按照不同颜色一个个将面积加起来就得到了最后的答案。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
#define lson L, mid, (rt<<1)
#define rson mid+1, R, (rt<<1|1)
using namespace std;
const int N = 1e5+10;
struct node
{
    double l,r,h;
    int temp;
    node(){}
    node(double x1,double x2,double y,int t):l(x1),r(x2),h(y),temp(t){}
    bool operator < (const node&nod)const{
        return h < nod.h;
    }
};
double sum[N<<2];
int cnt[N<<2];
vector<node> q;
vector<double>p;
int getid(double x)
{
    return lower_bound(p.begin(),p.end(),x) - p.begin();
}

void pushup(int l,int r,int rt)
{
    if(cnt[rt]) sum[rt] = p[r+1]-p[l];
    else if(l == r) sum[rt] = 0;
    else sum[rt] = sum[(rt<<1)]+sum[(rt<<1|1)];
}

void update(int L,int R,int rt,int l,int r,int temp)///l,r为查询区间
{
    if(l <= L&&R <= r)
    {
        cnt[rt] += temp;
        pushup(L,R,rt);
        return ;
    }
    int mid = (L+R)>>1;
    if(l <= mid)    update(lson,l,r,temp);
    if(r > mid)     update(rson,l,r,temp);
    pushup(L, R, rt);
}

int main()
{
    int n,cas = 0;
    while(scanf("%d",&n)==1&&n)
    {
        p.clear();
        q.clear();
        for(int i = 1;i <= n; i++)
        {
            double x1, y1, x2, y2;
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            q.push_back(node(x1,x2,y1,1));
            q.push_back(node(x1,x2,y2,-1));
            p.push_back(x1);
            p.push_back(x2);
        }
        sort(q.begin(),q.end());
        sort(p.begin(),p.end());
        p.erase(unique(p.begin(),p.end()),p.end());
        memset(cnt,0,sizeof(cnt));
        memset(sum,0,sizeof(sum));
        double ans = 0;
        int len = q.size();
        for(int i = 0;i < len-1; i++)
        {
            int l = getid(q[i].l);
            int r = getid(q[i].r)-1;
            if(l <= r)  update(0,p.size()-1,1, l, r,q[i].temp);
            ans += sum[1]*(q[i+1].h - q[i].h);
        }
        printf("Test case #%d\n",++cas);
        printf("Total explored area: %.2f\n\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值