UVA - 699 The Falling Leaves (二叉搜索和STL)

本文探讨了如何根据二叉树的前序遍历数据,计算各水平位置上叶子节点数值之和。通过使用map容器记录每个水平位置的累积值,并采用递归方式遍历树结构,最终输出从左到右各位置的总和。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?

We assume each node in a binary tree ”drops” a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there’s no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree on the right:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the ”leaves” drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value ‘-1’ is supplied. Thus the tree shown above is specified as ‘5 7 -1 6 -1 -1 3 -1 -1’. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single ‘-1’ (which would otherwise represent an empty tree).

Output

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of “leaves” in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input

5 7 -1 6 -1 -1 3 -1 -1

8 2 9 -1 -1 6 5 -1 -1 12 -1

-1 3 7 -1 -1 -1

-1

Sample Output

Case 1: 7 11 3

Case 2: 9 7 21 15

题目大意:一组数据根据前序遍历原则输入,当前节点的左儿子或者右儿子为空是输入的值为-1,以最上面的根节点为准线,以左减少一个水平位置,向右加一个水平位置,求从左向右对应位置的总和。

思路:使用map容器,使对应的位置所对应的值累加,对于树的遍历,采用递归。

#include<stdio.h>
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
map<int,int>mp;//实现映照关系
void inser(int x,int y)
{
    if(x==-1)
        return ;//当值为-1,即当前左or右为空
    mp[y]+=x;//实现对应的水平位置的值累加
    int a;
    scanf("%d",&a);//左
    inser(a,y-1);
    scanf("%d",&a);//右
    inser(a,y+1);
}
int main()
{
    int o=1;
    int x;
    while(~scanf("%d",&x)&&x!=-1)
    {
        mp.clear();//容器的清空
        inser(x,0);//
        printf("Case %d:\n",o++);
        map<int,int>::iterator it;//迭代器的遍历
        int flag=0;
        for(it=mp.begin(); it!=mp.end(); it++)
        {
            if(!flag)//first为键值,second为映照数据
                printf("%d",it->second);
            else
                printf(" %d",it->second);
            flag=1;
        }
        printf("\n\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值