POJ - 1789 Truck History

解决一个历史学家未能完成的任务,通过编程找出最高质量的卡车类型衍生计划,利用加权无向图和最小生成树的概念来确定最佳方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

 

题目大意: 以每i行的字符串(车牌)为基准,求第i行与其他行的差值,每个车牌的之间都有权值,求得一个所有车牌间的总权值Q,使得1/Q为高质量,说明Q最小,即最小生成树。

思路:加权无向图。转:http://www.cnblogs.com/Tree-dream/p/5565072.html

     举例:  

                     abaaaba                       以第一行为基准与各行的差值为 0 2 6 1

                     baaaaba                       以第二行为基准与各行的差值为 2 0 4 3

                     baabbab                       以第三行为基准与各行的差值为 6 4 0 5

                     abaaaaa                       以第四行为基准与各行的差值为 1 3 5 0

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int e[2010][2010];
int dis[2010];
int book[2010];
char s[2010][10];
int n;
int ans;
void creat()
{
    int i,j,k;
    int num;
    for(i=0; i<n; i++)
    {
        for(j=0; j<n; j++)
        {
            num=0;
            for(k=0; k<7; k++)
            {
                if(s[i][k]!=s[j][k])
                    num++;
            }
            e[i][j]=num;
        }
    }
}
void dijkstra()
{
    memset(book,0,sizeof(book));
    for(int i=0; i<n; i++)
        e[i][i]=0;
    for(int i=0; i<n; i++)
        dis[i]=e[0][i];
//    book[0]=1;
    int mi,u;
    for(int i=0; i<n; i++)
    {
        mi=inf;
        for(int j=0; j<n; j++)
        {
            if(!book[j]&&dis[j]<mi)
            {
                mi=dis[j];
                u=j;
            }
        }
        ans+=mi;
        book[u]=1;
        for(int v=0; v<n; v++)
        {
            if(!book[v]&&dis[v]>e[u][v])//**********
                dis[v]=e[u][v];//**************
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        ans=0;
        for(int i=0; i<n; i++)
            scanf("%s",&s[i]);
        creat();
        dijkstra();
        printf("The highest possible quality is 1/%d.\n",ans);
    }
    return 0;
}

 

内容概要:该论文研究了一种基于行波理论的输电线路故障诊断方法。当输电线路发生故障时,故障点会产生向两侧传播的电流和电压行波。通过相模变换对三相电流行波解耦,利用解耦后独立模量间的关系确定故障类型和相别,再采用小波变换模极大值法标定行波波头,从而计算故障点距离。仿真结果表明,该方法能准确识别故障类型和相别,并对故障点定位具有高精度。研究使用MATLAB进行仿真验证,为输电线路故障诊断提供了有效解决方案。文中详细介绍了三相电流信号生成、相模变换(Clarke变换)、小波变换波头检测、故障诊断主流程以及结果可视化等步骤,并通过多个实例验证了方法的有效性和准确性。 适合人群:具备一定电力系统基础知识和编程能力的专业人士,特别是从事电力系统保护与控制领域的工程师和技术人员。 使用场景及目标:①适用于电力系统的故障检测与诊断;②能够快速准确地识别输电线路的故障类型、相别及故障点位置;③为电力系统的安全稳定运行提供技术支持,减少停电时间和损失。 其他说明:该方法不仅在理论上进行了深入探讨,还提供了完整的Python代码实现,便于读者理解和实践。此外,文中还讨论了行波理论的核心公式、三相线路行波解耦、行波测距实现等关键技术点,并针对工程应用给出了注意事项,如波速校准、采样率要求、噪声处理等。这使得该方法不仅具有学术价值,也具有很强的实际应用前景。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值