SAM I AM
The world is in great danger!! Mental’s forces have returned to Earth to eradicate humankind. Our last hope to stop this great evil is Sam “Serious” Stone. Equipped with various powerful weapons, Serious Sam starts his mission to destroy the forces of evil. After fighting two days and three nights, Sam is now in front of the temple KOPTOS where Mental’s general Ugh Zan III is waiting for him. But this time, he has a serious problem. He is in shortage of ammo and a lot of enemies crawling inside the temple waiting for him. After rounding the temple Sam finds that the temple is in rectangle shape and he has the locations of all enemies in the temple. All of a sudden he realizes that he can kill the enemies without entering the temple using the great cannon ball which spits out a gigantic ball bigger than him killing anything it runs into and keeps on rolling until it finally explodes. But the cannonball can only shoot horizontally or vertically and all the enemies along the path of that cannon ball will be killed. Now he wants to save as many cannon balls as possible for fighting with Mental. So, he wants to know the minimum number of cannon balls and the positions from which he can shoot the cannonballs to eliminate all enemies from outside that temple.
Input
The input file contains several test cases. Here, the temple is defined as a R ×C grid. The first line of each test case contains 3 integers:R (0 < R < 1001), C (0 < C < 1001) representing the grid of temple (R means number of row and C means number of column of the grid) and the number of enemies N (0 < N < 1000001) inside the temple. After that there are N lines each of which contains 2 integers representing the position of the enemies in that temple. Each test case is followed by a new line (except the last one). Input is terminated when R = C = N = 0.
Output
For each test case there will be one line output. First print the minimum number (m) of cannonballs needed to wipe out the enemies followed by a single space and then m positions from which he can shoot those cannonballs. For shooting horizontally print ‘r’ followed by the row number and for vertical shooting print ‘c’ followed by the column number. If there is more than one solution any one will do.
Sample Input
4 4 3 1 1 1 4 3 2
4 4 2 1 1 2 2
0 0 0
Sample Output
2 r1 r3 2 r1 r2
思路:将行作为二分图左侧的点,列作为二分图右侧的点,即为求二分图的最小点覆盖数,就可以转化为求二分图的最大匹配数。这里的重难点在路径打印,解释在注释中给出
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e3 + 10;
int r, c, n;
int g[maxn][maxn], linkl[maxn], linkr[maxn], vis[maxn], a[maxn], b[maxn];
int vit[maxn];
int dfs(int x)
{
vis[x] = 1;
for(int i = 1; i <= c; i++)
{
if(!vit[i] && g[x][i])
{
vit[i] = 1;
if(!linkl[i] || dfs(linkl[i]))
{
linkl[i] = x;
linkr[x] = i;
return 1;
}
}
}
return 0;
}
int main()
{
while(cin >> r >> c >> n)
{
if(!r && !c && !n)
break;
memset(g, 0, sizeof(g));
int e = 0;
for(int i = 0; i < n; i++)
{
int x, y;
cin >> x >> y;
g[x][y] = 1;
}
int ans = 0;
memset(linkl, 0, sizeof(linkl));
memset(linkr, 0, sizeof(linkr));
for(int i = 1; i <= r; i++)
{
memset(vit, 0, sizeof(vit));
memset(vis, 0, sizeof(vis));
if(dfs(i))
ans++;
}
printf("%d", ans);
memset(vit, 0, sizeof(vit));
memset(vis, 0, sizeof(vis));//注意清空操作!
for(int i = 1; i <= r; i++)
{
if(!linkr[i])
dfs(i);//将左侧没有与右侧匹配的点作为起点进行匹配,将同侧与其右侧匹配点相同的点标记,同时标记右侧的与其有关系的点
}
for(int i = 1; i <= r; i++)
{
if(!vis[i])
printf(" r%d", i);
}
for(int i = 1; i <= c; i++)
{
if(vit[i])
printf(" c%d", i);
}
cout << endl;
}
return 0;
}