CodeForces 611 A. New Year and Days(水~)

Description
两种询问问每周和每月的第x天在2016年有几个
Input
两种询问
x of week(1<=x<=7)
x of month(1<=x<=31)
Output
输出每周和每月的第x天在2016年有几个
Sample Input
4 of week
Sample Output
52
Solution
水题~
Code

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int d;
char s1[3],s2[6];
int main()
{
    while(~scanf("%d%s%s",&d,s1,s2))
    {
        if(s2[0]=='w')
        {
            if(d==5||d==6)printf("53\n");
            else printf("52\n");
        }
        else 
        {
            if(d<=29)printf("12\n");
            else if(d==30)printf("11\n");
            else if(d==31)printf("7\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值