Description
输入一个十进制数N,将它转换成R进制数输出
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)
Sample Input
7 2
23 12
-4 3
Sample Output
111
1B
-11
Solution
进制转换,每次将N%R压进栈中,把N R进制拆分后从栈顶那元素,如果小于10则直接输出即可,如果大于10则将其转化为字母输出(+55即可)
Code
#include<cstdio>
#include<cstring>
#include<iostream>
#include<stack>
using namespace std;
int main()
{
int n,r;
while(scanf("%d%d",&n,&r)!=EOF)
{
if(n<0)
printf("-"),n=-n;
stack<int> s;
while(n)
{
int temp=n%r;
s.push(temp);
n/=r;
}
while(!s.empty())
{
int temp=s.top();
s.pop();
if(temp<10)
printf("%d",temp);
else
printf("%c",temp+55);
}
printf("\n");
}
return 0;
}