Period
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5221 Accepted Submission(s): 2515
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
题解:处理next数组,用i减去next[i],如果说这个值可以被i整除,那么这个剩下来的串一定是最短的周期。这个画个图就大概能懂了.....
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[1000005];
int n,next1[1000005],ans[1000005],h;
void getnext(char s[])
{
int l=strlen(s);
memset(next1,0,sizeof(next1));
next1[0]=0;
next1[1]=0;
int i=1,k;
while (i<l)
{
k=next1[i];
while (k!=0)
{
if (s[k]==s[i])
{
next1[i+1]=k+1;
break;
}
else k=next1[k];
}
if (k==0 && s[i]==s[0]) next1[i+1]=1;
i++;
}
}
int main()
{
int Case=0;
while (scanf("%d",&n),n)
{
memset(ans,0,sizeof(ans));
Case++;
printf("Test case #%d\n",Case);
memset(s,0,sizeof(s));
scanf("%s",s);
getnext(s);
int l=strlen(s);
for (int i=2;i<=l;i++) if (i%(i-next1[i])==0 && next1[i]) ans[i]=i-next1[i];
for (int i=1;i<=l;i++) if (ans[i]) printf("%d %d\n",i,i/ans[i]);
printf("\n");
}
return 0;
}