Power Strings

题目描述:

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

输入:

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出:

For each s you should print the largest n such that s = a^n for some string a.

样例输入:

abcd
aaaa
ababab
.

样例输出:

1
4
3

提示:

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

code:

题目大意: 给出一个字符串 问它最多由多少相同的字串组成

KMP:
用next数组求出整个数组的最大前缀,如果整个串是用循环节组成的,那么 n - next[n] 也就是最小循环节,验证最小循环节会被n整出。

#include<stdio.h>
#include<string.h>
const int maxn=1e6+10;
char a[maxn];
int nextt[maxn]; 
int n;
void init()
{
	int i=0,j=-1;
	n=strlen(a);
	nextt[0]=-1;
	int maxx=1;
	while(i<n)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			nextt[i]=j;
		}
		else j=nextt[j];
	}
}
int main()
{
	while(1)
	{
		scanf("%s",a);
		if(a[0]=='.')break;
		init(); 
		int n=strlen(a);
		if(n%(n-nextt[n])==0)printf("%d\n",n/(n-nextt[n]));
		else printf("1\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值