天梯赛 L2-013 红色警报 (25 分)
题目
战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。
输入
输入在第一行给出两个整数N
(0 < N ≤ 500)和M
(≤ 5000),分别为城市个数(于是默认城市从0到N-1
编号)和连接两城市的通路条数。随后M
行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K
和随后的K
个被攻占的城市的编号。
注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。
输出格式:
对每个被攻占的城市,如果它会改变整个国家的连通性,则输出Red Alert: City k is lost!
,其中k是该城市的编号;否则只输出City k is lost.
即可。如果该国失去了最后一个城市,则增加一行输出Game Over.
。
测试样例
输入样例:
5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3
输出样例:
City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.
简单分析:
- DFS暴搜
- 并查集
代码:
1.暴搜
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
const int N = 510;
int n, m, k;
vector<int> g[N];
bool st[N];
void dfs(int u) {
st[u] = true;
for (int i = 0; i < g[u].size(); i++)
if (!st[g[u][i]])
dfs(g[u][i]);
}
int cnt() {
int cnt = 0;
for (int i = 0; i < n; i++)
if (!st[i]) {
cnt++;
dfs(i);
}
memset(st, 0, sizeof st);
return cnt;
}
int main() {
cin >> n >> m;
for (int i = 0; i < m; i++) {
int a, b;
cin >> a >> b;
g[a].push_back(b);
g[b].push_back(a);
}
int sum = cnt();
vector<int> lost;
cin >> k;
for (int i = 0; i < k; i++) {
int x;
cin >> x;
lost.push_back(x);
for (int j = 0; j < lost.size(); j++)
st[lost[j]] = true;
int cur = cnt();
if (cur <= sum) printf("City %d is lost.\n", x);
else printf("Red Alert: City %d is lost!\n", x);
sum = cur;
}
if (n == lost.size()) puts("Game Over.");
return 0;
}
2.并查集
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 1e4;
int n, m, k;
int p[N];
bool st[N];
struct node {
int x, y;
}a[N];
int find(int x) {
if (p[x] != x) p[x] = find(p[x]);
return p[x];
}
void merge(int x, int y) {
x = find(x), y = find(y);
p[x] = y;
}
int main() {
cin >> n >> m;
for (int i = 1; i < n; i++) p[i] = i;
for (int i = 0; i < m; i++) {
cin >> a[i].x >> a[i].y;
merge(a[i].x, a[i].y);
}
int sum = 0;
for (int i = 0; i < n; i++)
if (p[i] == i)
sum++;
cin >> k;
bool flag = false;
if (k >= n) flag = true;
while (k--) {
int x, cnt = 0;
cin >> x;
st[x] = true;
for (int i = 0; i < n; i++) p[i] = i;
for (int i = 0; i < m; i++) {
if (st[a[i].x] || st[a[i].y]) continue;
merge(a[i].x, a[i].y);
}
for (int i = 0; i < n; i++)
if (p[i] == i)
cnt++;
if (cnt == sum || cnt - 1 == sum) printf("City %d is lost.\n", x);
else printf("Red Alert: City %d is lost!\n", x);
sum = cnt;
}
if (flag) puts("Game Over.");
return 0;
}
感悟
努力学习中