FatMouse and Cheese 【HDU - 1078 】

本文介绍了一道经典的算法题目——FatMouse如何在限定步数内,沿着数值递增路径,从矩阵左上角出发获取最大奶酪数量。文章通过深度优先搜索策略实现动态规划算法,最终给出最优解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:

题意就是在n的方阵中,从最左上角,每次横向或纵向走k步,每走一步都要求下一步的数字比上一步的数字更大,从起点开始走到一处求和求到一处,求出最大的和。

代码:

#include<stdio.h>
#include<iostream>
using namespace std;

int n,k;
int e[101][101],dp[101][101];
int dx[4]={0,0,1,-1},dy[4]={1,-1,0,0};

int dfs(int x,int y)
{
	if(dp[x][y]) 
	   return dp[x][y];
	   
	int ans=0;
	for(int i=0;i<4;i++)
	{
		for(int j=1;j<=k;j++)
		{
			int r,c;
			r=x+j*dx[i];
			c=y+j*dy[i];
			if(r>=0 && r<n && c>=0 && c<n && e[r][c]>e[x][y])
			{
				int t=dfs(r,c);
				if(ans<t) 
				   ans=t;
			}
		}
	}
	dp[x][y]=ans+e[x][y];
	return dp[x][y];
}

int main()
{
	while(cin >> n >> k)
	{
		if(n==-1 && k==-1)
		     break;

		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
			{
				cin >> e[i][j];
				dp[i][j]=0;
			}
		dfs(0,0);
		cout << dp[0][0] <<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值