poj2480Longge's problem数论积性函数

Longge’s problem

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N.
“Oh, I know, I know!” Longge shouts! But do you know? Please solve it.
Input
Input contain several test case.
A number N per line.
Output
For each N, output ,∑gcd(i, N) 1<=i <=N, a line
Sample Input
2
6
Sample Output
3
15

数论还是难呀,看了一下午终于看懂了。
官方解析如下:

但是,依旧看不懂AC代码。
我们通过一系列证明:(不会Latex的弱鸡)
这里写图片描述
代码如下:

#include <iostream>
using namespace std;
typedef long long ll;
int main()
{
    ll n;
    while(cin>>n){
        ll ans=n;
        for(ll i=2;i*i<=n;i++){
            if(n%i==0){
                ll a=0,p=i;
                while(n%p==0){
                    a++;
                    n/=p;
                }
                ans=ans+ans*a*(p-1)/p;
            }
        }
        if(n!=1)
            ans=ans+ans*(n-1)/n;
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jamence

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值