poj3279 Fliptile(翻转棋盘)

本文详细介绍了如何解决POJ3279编程题,重点讨论了翻转棋盘问题的算法思路,通过实例解析翻转过程,帮助读者理解并掌握解题技巧。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers:  M and  N 
Lines 2..  M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white
Output
Lines 1..  M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

真的年轻呀,我想用dfs管用的·套路,定义结构体,在结构体中存储整个图,作为一个状态,但是太可怕了。用bfs来对不同状态进行转换。

#include <iostream>
#include <cstring>
using namespace std;
const int maxn=20;
int m,n;
//用于保留变换结果 
int vis[maxn][maxn];
//用于保留图中间过程 
int temp[maxn][maxn]; 
//用于保留图最终结果 
int res[maxn][maxn];
//用于保留最初
int fron[maxn][maxn]; 
int ans;
void flip(int i,int j)
{
	temp[i][j]^=1;
	if(i-1>=0)temp[i-1][j]^=1;
	if(j-1>=0)temp[i][j-1]^=1;
	if(j+1<n)temp[i][j+1]^=1;
	if(i+1<m)temp[i+1][j]^=1;
}
void solve()
{
	//枚举第一行的所有情况 
	for(int i=0;i<(1<<n);i++){
		memset(vis,0,sizeof vis);
		memcpy(temp,fron,sizeof fron);
		for(int j=0;j<n;j++){
			if(i&(1<<j) ){
				flip(0,j);
				vis[0][j]=1;
			}
		}
		for(int j=1;j<m;j++){
			for(int k=0;k<n;k++){
				if(temp[j-1][k]){
					flip(j,k);
					vis[j][k]=1;
				}
			}
		}
		bool flag=0;
		for(int j=0;j<m;j++)
			if(temp[m-1][j]){
				flag=1;
				break;
			}
		if(!flag){
			int res1=0;
			for(int j=0;j<m;j++)
			for(int k=0;k<n;k++)if(vis[j][k])res1++;
			if(res1<ans){
				ans=res1;
				memcpy(res,vis,sizeof vis);
			}
		}
	}
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>m>>n){
		if(m==0||n==0)break;
		ans=0xffffff;
		for(int i=0;i<m;i++)
		for(int j=0;j<n;j++)cin>>fron[i][j];
		solve();
		if(ans==0xffffff)
			cout<<"IMPOSSIBLE"<<endl;
		else{
			for(int i=0;i<m;i++){
				for(int j=0;j<n;j++){
					if(j==0)cout<<res[i][j];
					else
					cout<<" "<<res[i][j];
				}
			cout<<endl;
			}
		}
		
	}	
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jamence

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值