HDU_2602 Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 49986 Accepted Submission(s): 20965
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
套0-1背包公式,直接写。
#include <bits/stdc++.h>
using namespace std;
const int maxn=1010;
int ans[maxn];
int value[maxn],volum[maxn];
int main(int argc,char *argv[])
{
// freopen("data.in.txt","r",stdin);
int ncase;
cin>>ncase;
while(ncase--){
int n,v;
cin>>n>>v;
for(int i=1;i<=n;i++)
cin>>value[i];
for(int i=1;i<=n;i++)
cin>>volum[i];
memset(ans,0,sizeof(ans));
for(int i=1;i<=n;i++)
for(int j=v;j>=0;j--){
if(j>=volum[i])
ans[j]=max(ans[j],ans[j-volum[i]]+value[i]);
}
cout<<ans[v]<<endl;
}
return 0;
}